Setting up soundmodem on Ubuntu 10.04

After a long delay, I finally decided to upgrade to 10.04 LTS and get soundmodem running again.

Luckily, there was help this time. I started with my config, and merged with this post:
ubuntuforums.org/showthread.php?p=10864691

Here’s the config I ended up using:

Configuration: AX.25
IO:
Mode: soundcard
Audio Driver: /dev/dsp
Half Duplex: selected
PTT Driver: none

Channel Access:
TxDelay: 150
Slot Time: 100
P-Persistence: 40
Full Duplex: not selected
TxTail: 10

Channel 0:
Modulator:
Mode: afsk
Bits/s: 1200
Freq 0: 1200
Freq 1: 2200
Differential: selected

Demodulator:
Mode: afsk
Bits/s: 1200
Freq 0: 1200
Freq 1: 2200
Differential: selected

Packet IO:
Mode: MKISS
Interface: sm0
Callsign: mycall
IP address: 10.0.0.1
Network mask: 255.255.255.0
Broadcast addr: 10.0.0.255

I also set up /etc/ax25/axports to have:

sm0 mycall 1200 255 7 144.39 APRS (1200 bps)

Finally, I made sure Avahi was set to ignore sm0. This is easier than it was prevously – now you just add:

deny-interfaces=sm0

to /etc/avahi/avahi-daemon.conf

Once that’s done, don’t forget to chmod 4755 /usr/bin/xastir so it can open sm0 and things are good.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: